Product Series: QuiQ |
Article No: FAQ050 |
Symptom:
The charger goes through its startup cycle continuously as in the attached video.
Cause:
The paddle, supplied by Anderson Power Products, has a known weakness in the wiper. See image below showing the two power pins and the spring-loaded wiper.
Over time or due to debris, the wiper (green wire) makes poor or no contact with the outside of the receptacle Battery Negative Pin, causing the charger to reset as this pin is normally used to detect disconnection to prevent sparking.
Resolution:
- Clean the contact without opening it.
- Open the connector as shown above and clean the contact.
- Open the connector as shown above and bend the contact to restore the spring.
Contact E-Z-GO/Textron for more details on this connector.
- IMG_8391.TRIM.MOV10 MB